Subject: [css-d] Media="all" vs. @import

From: Craig.Saila at bgminteractive.com (Saila, Craig)
Date: Thu, 24 Apr 2003 16:08:02 -0400

James Craig wrote:
> I admit I haven't been paying as close attention to this thread as
> possible, but what do you guys think of adding @media rules? Would
> this work?

That's exactly the way to go, and is what @media is designed for. The
problem is, AFAIK, @media isn't well supported in some browser that have
good CSS support like IE5/Mac and some versions of KHTML-based browsers.

> <link rel=3D"stylesheet" type=3D"text/css" media=3D"all" />
>=20
> Then the stylesheet could include general styles still hidden from
> Netscape 4, immediately followed by:
>=20
> @media screen {
>    @import "screen.css";
> }
> @media print {
>    @import "print.css";
> }
>=20
> Perhaps there are some bugs associated with this approach, too?

That's kinda overkill if you're using it to block NN4, but it's the
ideal way to work with media=3D"all" in that you're using @media.=20

The reason I say it's overkill is because NN4 doesn't get @import, so
this, for example, would be just as good:

 <style type=3D"text/css" media=3D"all">
  /* all-media general styles not for NN4 */
 </style>
 <style type=3D"text/css">
  @import "screen.css" screen;
  @import "print.css" print;
 </style>

Or within that media=3D"all" CSS file (although I'm not sure if @media =
has
to come first, like @import):

  /* all-media general styles not for NN4 */
 @media screen {
   /*rules for screen*/
 }
 @media print {
   /*rules for print*/
 }

--=20
Cheers,

Craig Saila
------------------------------------------
[email-masked] : http://www.saila.com/
------------------------------------------

---

From: matt.davey at dsl.pipex.com (Matthew Davey)
Date: Sat, 26 Apr 2003 19:55:28 +0100

Not sent to the list.

-----Original Message-----
From: Matthew Davey [mailto:[email-masked]] 
Sent: Saturday, April 26, 2003 7:48 PM
To: 'Brandy (mediadiva)'
Subject: RE: [css-d] Media="all" vs. @import

I don't think so . . .

}-----Original Message-----
}From: [email-masked] 
}[mailto:[email-masked]] On Behalf Of 
}Brandy (mediadiva)
}Sent: Saturday, April 26, 2003 6:55 PM
}To: John Lewis; [email-masked]
}Subject: Re: [css-d] Media="all" vs. @import
}
}
}can you have more then one import?
}
}
}----- Original Message ----- 
}From: "John Lewis" <[email-masked]>
}To: <[email-masked]>
}Sent: Friday, April 25, 2003 6:49 PM
}Subject: Re: [css-d] Media="all" vs. @import
}
}
}> Brandy wrote on Friday, April 25, 2003 at 5:40:10 PM:
}> 
}> > can you have more then one media="all" on a page?
}> 
}> Yes. It simply means that each style sheet will be applied in all
}> media (screen, handheld, projection, and so on). For example,
}> 
}> <link rel="stylesheet" type="text/css" href="/global.css" 
}media="all">
}> <link rel="stylesheet" type="text/css" href="local.css" media="all">
}> 
}> -- 
}> John Lewis
}> 
}> 
}______________________________________________________________________
}> css-discuss [[email-masked]]
}> http://www.css-discuss.org/mailman/listinfo/css-d
}> Supported by evolt.org -- http://www.evolt.org/help_support_evolt/
}______________________________________________________________________
}css-discuss [[email-masked]]
}http://www.css-discuss.org/mailman/listinfo/css-d
}Supported by evolt.org -- http://www.evolt.org/help_support_evolt/
}