Subject: [css-d] Min-height

From: robert.nyman at centus.com (Robert Nyman)
Date: Fri, 25 Apr 2003 11:28:02 +0200

> So, is there a workaround that lets you make an element at least x
pixels high,=20
while still allowing it to expand to bigger if necessary?
In IE on PC, it will expand if you have set the height to 20px and its
content is bigger...
However, you can't use min-height and height in conjunction for Gecko
etc.

So, for IE on PC, use this:

height:20px;

and for standrads-compliant browsers, use this:

min-height:20px;

/Robert

---

From: rijk at opera.com (Rijk van Geijtenbeek)
Date: Fri, 25 Apr 2003 11:46:42 +0200

On Fri, 25 Apr 2003 11:28:02 +0200, Robert Nyman <[email-masked]> 
wrote:

>> pixels high, while still allowing it to expand to bigger if necessary?

> and for standrads-compliant browsers, use this:

For example like this:

div {height:20px; min-height:20px;}
html>body div {height:auto;}

-- 
 If you don't like having choices    |  Rijk van Geijtenbeek
 made for you, you should start      |   Documentation & QA
 making your own. -  Neal Stephenson |  mailto:[email-masked] M