Subject: [css-d] position:fixed and IE

From: ken at kpmartin.com (Ken Martin)
Date: Fri, 25 Apr 2003 10:09:05 -0500

I checked the wiki and didn't see anything, though I suspect this is 
probably frequently asked.

Does PC IE support position:fixed? It appears not to. I'm wondering if 
I need to use it in tandem with other declarations or if it simply 
doesn't work.

TIA

Ken Martin

---

From: gary at star-chaser.com (Gary)
Date: Fri, 25 Apr 2003 12:01:57 -0400

Ken Martin wrote:
> Does PC IE support position:fixed? It appears not to. I'm wondering if I 
> need to use it in tandem with other declarations or if it simply doesn't 
> work.
> 

It only supports position:fixed on backgrounds. You can get it to work 
in two ways.

Javascript
http://doxdesk.com/software/js/fixed.html

conditional comments
http://devnull.tagsoup.com/fixed/

HTH
Gary

-- 
Gary Bland
StarChaser Web Architecture
http://www.star-chaser.com
Building Tomorrow's World Today

The Nemesis Project
http://nemesis1.f2o.org
One Stop CSS