Subject: [css-d] IE 6 vs Opera/Mozilla etc

From: stephen at crescentcreative.com (Stephen Hamilton)
Date: Thu, 24 Apr 2003 14:01:18 -0700

I don't know if it's correct form to reply to your own messages, but I
solved most of my nested list / rollover issues with one remaining niggle.

My original problem was caused by not nesting the list elements properly
viz:

	<ul>
		<li>element1</li>
		<ul>
			<li>subelement1</li>
		</ul>
		<li>element2</li>
	</ul>

That piece is now corrected.

However I still have the problem that IE6.0 is not picking up the color
attribute.  This too will succumb to engineering rigor!

Any pointers are always appreciated.

Stephen

-----Original Message-----
From: Stephen Hamilton [mailto:[email-masked]]
Sent: Wednesday, April 23, 2003 9:44 PM
To: [email-masked]
Subject: [css-d] IE 6 vs Opera/Mozilla etc

I have built nested left navigation menus with CSS rollovers on a site
(www.saveburlingameschools.com) and find significant differences from IE6
versus Opera 7.1 , Netscape 7.0 , and Mozilla 1.3 (all W2K)

1) IE does not pick up the color attribute for the text link:

.navbar li a {
 <snip>
  color: #880026;
 }

2) and IE does not pick up the submenu background image:

http://www.saveburlingameschools.com/index.php?Topic=5

.subnavbar li a  {
 <snip>
  background-image: url('pictures/submenu.gif');
  background-repeat: no-repeat;
  text-decoration: none;

All the other mentioned browsers seem to work ok (though there is a strange
framing ssue with Mozilla that I haven't quite resolved!).

The style sheets are at :
http://www.saveburlingameschools.com/measurea.css
http://www.saveburlingameschools.com/measurealayout.css

Any thoughts / pointers would be appreciated.

Many thanks

Stephen

"There are many roads up the mountain, but they all lead to the top   ...
The road is steep whichever way you go, so enjoy the view!"

---

From: rudy937 at rogers.com (rudy)
Date: Thu, 24 Apr 2003 17:44:06 -0400

> (www.saveburlingameschools.com)

i love the apple with the bite out of it!

however, the colours on the nav links are identical in ie6 and mozilla, and
in fact are no different in link versus hover status

hover underlines the links in both browsers

rudy

---

From: kr43m0r at earthlink.net (Lonnie)
Date: Thu, 24 Apr 2003 17:02:01 -0500

> attribute.  This too will succumb to engineering rigor!

Link colors are controlled by pseudo-classes.

.navbar li a:link {
color: #880026;
}

Lonnie