Subject: [css-d] List-marker color

From: ckestes at bewb.org (Jason Estes)
Date: Fri, 25 Apr 2003 10:30:24 -0500

Does anyone know, I didn't see it in  the CSS spec, if or how you can change
the list-item-marker's color?

I'd like the color of the markers to be the same as the color of my text,
but I didn't see any reference to color in the CSS spec.

Anyone?

Jason Estes
The BEWB
www.bewb.org

---

From: jgay at tla.com (Jim Gay)
Date: Fri, 25 Apr 2003 12:16:02 -0400

> but I didn't see any reference to color in the CSS spec.

http://www.w3.org/TR/REC-CSS2/generate.html#lists

you can't change the color of the marker alone (e.g. separately from its
corresponding line), but you can change its image using list-style-image

---

From: ckestes at bewb.org (Jason Estes)
Date: Fri, 25 Apr 2003 11:30:11 -0500

> corresponding line), but you can change its image using list-style-image

Technically I guess you could if you did something like this

<li style="color:red"><span style="color:#000;">sdaf </span></li>

then you end up with red bullets and black text.

Jason Estes
The BEWB
www.bewb.org

---

From: gleemax at attbi.com (John Lewis)
Date: Fri, 25 Apr 2003 11:18:54 -0500

Jason wrote on Friday, April 25, 2003 at 10:30:24 AM:

> Does anyone know, I didn't see it in the CSS spec, if or how you can
> change the list-item-marker's color?

> I'd like the color of the markers to be the same as the color of my
> text, but I didn't see any reference to color in the CSS spec.

If you're using generated content:

    li:before{color:#000}

Otherwise I'd need to check. It may be unspecified, or it may match
the list-item's color. I don't think there's a special way of doing
it, though.

-- 
John Lewis